Slow load times
Incident Report for Presentator.io
Resolved
All systems are back to normal.
Posted over 1 year ago. Feb 17, 2018 - 13:39 UTC
Monitoring
Due to high demand, some users may experience slower than normal load times. All systems are operational and we appreciate your patience while we monitor.
Posted over 1 year ago. Feb 17, 2018 - 12:13 UTC