Internal server error
Incident Report for Presentator.io
Resolved
This incident has been resolved.
Posted about 2 years ago. Sep 23, 2017 - 16:49 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 2 years ago. Sep 23, 2017 - 16:41 UTC
Investigating
We are currently investigating this issue.
Posted about 2 years ago. Sep 23, 2017 - 16:40 UTC