Slow load times
Incident Report for Presentator.io
Resolved
All systems are back to normal.
Posted about 1 year ago. Dec 12, 2017 - 09:28 UTC
Monitoring
Due to high demand, some users may experience slower than normal load times. All systems are operational and we appreciate your patience while we monitor.
Posted about 1 year ago. Dec 12, 2017 - 08:56 UTC