Service Temporarily Unavailable
Incident Report for Presentator.io
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 18, 2019 - 11:09 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Apr 18, 2019 - 10:49 UTC
This incident affected: App and API.